Doxie Legacy Downloads for Mac

If you're using an older Mac with OS X 10.9 or earlier, you won't be able to run the latest versions of the Doxie app. Instead, you should download these legacy versions that will work on your older setup:

OS X 10.6 or earlier

Download Doxie 2.6 here. Doxie 2.6 is compatible with:

OS X 10.7 - 10.9

Download Doxie 2.10.3 for OS X if you are running OS X 10.7, 10.8, or 10.9. Doxie 2.10.3 is compatible with:

If you have a Mac running a more up-to-date version of OS X, you should not download these files – instead, download the current version from our main support site.

Tip: Turn off automatic update notifications

You may wish to turn off automatic update notifications so that you are not prompted to update to later versions -- but be sure to update in the future if and when you upgrade your OS. Simply uncheck the "Check for software updates" option in Doxie's preferences pane.